Supervised Wishart Classification - Quad-pol RADARSAT2

I use Radarsat2, also get the error, so sad

basically, you can still derive polarimetric decompositions and use them as features for a supervised random forest classification. It’s not based on clusters then but still on the polarimetric features.

Thanks for your patient answer,I will have a try:blush:

if you only have few classes, a k-means clustering might already be sufficient

Another question,If I can decomposition for Sentinel-1A SLC or GRD? Sentinel-1A has only two polarizations.

there are some decompositions which also work for Dual-polarized data but the results are not very good.
There are some discussions on to what extent it makes sense for Sentinel-1 data:

Hi I have generated T3 matrix from Radarsat-2 Quadpol data. Applying lee filter and i also want to perform the wishart classification. I am getting the same error after choosing the training data as text file generated in supervised classification. what should i do in this, Please help …Thanks in advance

please post the error message. We cannot help without this information.

i also get the same error what should i do can anyone please guide in this matter

I can reproduce the error


@lveci @jun_lu Could we add this to the bug list?

A JIRA ticket has been created to track the issue:

I’ve just tried the processing chain (refined Lee filtering => Supervised Wishart Classification Training => Supervised Wishart Classification) with RS2 full-pol data on my computer and have no problem. Here I used Refined Lee Filter in Polarimetric Speckle Filter and the output is in T3 matrix format. For Washart classification, the input should be in either the original full-pol format or in coherence matrix T3 format. But if I forget to specify the location of the “Training Data Set” file in the UI of the Supervised Wishart Classification operator, then I got the following error.

Which java version have you installed in your system.

that’s strange, when I apply the polarimetric speckle filter (output is T-matrix), train three classes and apply the trained cluster centers to the trained image, I still get the error:

Could you please share your training txt so I can check if they are somehow different?
This is mine: cluster_centers.txt (1.1 KB)

Here is my training txttraining_cluster_centers.txt (2.3 KB)

Did you use the Radarsat Vancouver dataset as well?

the files look similar regarding their structure but when I apply your clusters to my data, the error message persists.

openjdk version “1.8.0_232”

Yes, here is the data set I used