using sen2cor to convert TOA product into BOA product in sentinel 2A image from 2016 February

I have an image of Lahore city from sentinel 2A which dates to 2016 February 17. I used sen2cor algorithm in SNAP to convert the level 1C to level 2A product. But I kept receiving the empty folders. The processed image file appeared inside the (unzipped) original folder with 2A instead of 1C. Everything appeared normal except when I tried to open the processed image in SNAP, there was nothing inside the R10m, R20m and R60m folders inside IMG_DATA. There was an exception inside R20m folder though which had a H5 file format named “.database.h5”. Guessing that I might have done some mistake installing the sen2cor plugin, I copied the image in my friend’s laptop to try the process in her SNAP. (she had used sen2cor with sentinel 1C images in the past and had no issue). But I had no luck, I still got the empty folders. Please provide me some guidelines.

have you tried to run sen2cor from the command line? It’s easy to apply and less prone to configuration errors.
Please see this comment here: Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File'

Hi ABraun, thank you for reaching out. I tried to run sen2cor from command line. It went smoothly at first then after few minutes it gave me this message: AttributeError: ‘L2A_Tables’ object has no attribute ‘_L2A_Tile_PVI_File’. Please provide me further guidelines.

Hi again, I recently saw your past comments on other’s post. I will start with 60 m then with 20 m and finally with 10 m. I will try this first.
Thanks again!

actually, to get 10 m resolution, no flag has to be set, just
L2A_process S2_FOLDER.SAFE

Hi ABraun

I tried everything accordingly and it worked great. It takes lot less time than in SNAP as well. However, I ran into something. While the command line worked perfectly yesterday, I started to get no results at all today and learned that somehow I have overwritten the L2A_Process.bat file. Because when I went inside the folder it says “0 KB” beside the batch file. Is there a way to download it separately or should I reinstall sen2cor? Please let me know.

That is strange, I cannot imagine how this happened, because it is only executed, not actively written.
But you can download the bundle as a zip file from the sen2cor homepage and only use the bat file inside to replace the empty one.

Hi ABraun
I will try that and let you know. Thank you very much once again.