Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File'


I am trying to process at 10 m and I continue to get this error:
AttributeError: ‘L2A_Tables’ Object has no attribute ‘_L2A_Tile_PVI_File’
Is anyone familiar with this/ have any solutions?

Thanks in advance,


1 Like


I got the same error, and solved it by processing 20 m first.

Some parameters seems to be messed up when the 10 m function tries to call the 20 m one.




Thank you for the reply. Would you mind explaining to me how I might do this? When I attempt to include the 20 m into the processing I get an error asking for the L1C and that it doesn’t fit a certain mask.

Thank you again,


Dear Users,

In order to run Sen2Cor 2.5.5 at 10m resolution, you do not have to specify the ‘–resolution’ field.

Please perform the following steps to process Sen2Cor at 10m resolution:

  1. go in the folder containing the ‘L2A_Process.bat’ (e.g. “C:\Sen2Cor-02.05.05-win64”)
  2. digit “L2A_Process.bat [directory_name]”
    –> e.g. "L2A_Process.bat C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE

To run Sen2Cor at 20m resolution:
“L2A_Process.bat --resolution 20 [directory_name]”
–> e.g. “L2A_Process.bat --resolution 20 C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE”

To run Sen2Cor at 60m resolution:
“L2A_Process.bat --resolution 60 [directory_name]”
–> e.g. “L2A_Process.bat --resolution 60 C:\S2A_MSIL1C_20170316T094021_N0204_R036_T33SVB_20170316T094506.SAFE”

Best Regards,


There is no way to generate the 10 m on its own? Thank you. This was helpful!

Is that the solution of the problem with 10m resolution?. It would be important to know I think @OHagolle

I do confirm that running sen2cor standalone without specifying the resolution will return the 10m level2 product with no errors.


Hi, I can confirm it works. Thanks for the answers !

I did not specify any resolution but it processed all. My machine is Ubuntu.

Hi Fabrizio,

In my practice, your solution for 10m resolution generates all three resolution. Is it possible to only generate 10m and 20m resolutions?

Thank you.

Hello what does it mean make option ‘all’ in paramaters résolution when runing sen2cor

Sentinel-2 has bands of different resolution:

Yes i understand but when i run sen2cor with all or 60 or 20 m the attmosferic correction done correctely but when i run sen2cor with directley 10 m in paramaters he start processing but for a few second he stop working bug
What ils the problem here

did you try it from the command line as suggested by @Fabrizio_Ramoino a couple of posts above?

For processing of the 10m images, data from the 20/60m images are needed as input. That is, for 10m L2A products one anyways has to process the 20/60m data. It seems there is a bug (at least in the SNAP plugin), that doesn’t trigger the 20/60m (pre-)processing correctly when 10m resolution is selected.

workaround #1 (as suggested here): choose ‘all’ for resolutions to process.

workaround #2 (haven’t tried that yet, though): do the 20m (and maybe 60m, too. just test…) processing first, then the 10m after without moving or renaming the L2A output folder. This way the 10m processing should recognize that there is (the required pre-processing) data in the L2A output folder and apply this.

1 Like

When i shoose all i got a result of all résolution 10 20 60

In fact i dont use command line
Si i will run sen2cor with 60 m when processus finshed i will run sen2cor with 20 m when finish i will run sen2cor with 10 m withaut changing name of output. Product

yes, that’s the definition of ‘all’. Anything wrong with that?

yes, like that. you can probably leave out the separate 60m processing. just try it out…

Thanks helping me