Calibration in PolSARpro problem

since i had to extract two or more different time series images to be used for tom_sar later on, i extracted them into seperate folders

for me it worked like this:

  1. Extract image 1
  2. Extract image 2
  3. Add both extrated images in the "Multi Data Sets (Pol-TomSAR) dialogue
  4. The Polarimetric Tomography menu appears

Any solution to this ?

Ok done till step 4 but now it’s saying config file not found, any idea why this error ?

i am getting an error message in polrimteric tomography function when i am selecting my bmp file to select area. what do i do? any idea why this error?

I tried again and am still not getting any results. So I will share the steps I undertook with two ALOS PALSAR QuadPol scenes so we can maybe together find out how to proceed:

I followed these tutorials and documents:

1. Create working directory “Single Data Set (PolSAR)”

I select the folder where the original data is stored and click “Save & Exit”. I confirm the upcoming message and proceed with the file import.

2. Import the scene

I select a different (by now empty) output directory so the imported data can be stored here seperately in PolSARpro format
I select the LED file and click “read header”. Everything is fine so far. I confirm with “OK”. Message “Dont forget to extract the data.”

3. Extract the data

I select some subset coordinates and click on “OK”

A valid pixel mask and an RGB image are created

4. Repeat steps 1-3 with second QuadPol scene

I do the same with the second data set, I select a different output folder so both images are stored seperately.
Set the environment, load the data. Extract the data. I now have two folders with PolSARpro products.

5. Load both scenes for the TomSAR processing

Environment > Multi Data Sets (Time Series Data / Pol-Tom SAR)
I first select the first folder, then click “New” and add the second folder. So I have 1/2 and 2/2. I select the S2 matrix and click “Save & Exit”

6. Start the TomSAR dialogue

Load > Polarimetric Tomography
I get asked for a BMP file so I select one of the two generated Pauli RGBs

7. Generate DEM files

I enter DEM values and click “Gene” in order to generate DEM files. I select the checkboxes in the subsequent windows and click “Run”.

8. Display coherence map

DEM files are now generated and I start the coherence map generation

Results are looking great

9. Run it with DEM compensation

Checkbox “DEM compensation” then “Run”.

Here I get a runtime error and don’t know why

I also don’t know where to check for more detailled error messages. So I can’t go on with the profile analysis as described in the tutorials.
Running the analysis without the DEM compensation leads to the same error message.

So if anyone is able to add some ideas to this, I would be glad about a discussion.

  • Is the process of importing the data correct?
  • Do I need to co-register the data in a way?
  • Do I miss a crucial point in the TomSAR dialogue?

Is it possible to do tomsar with dual pol ALOS PALSAR 1 data?

technically, Dual-Polarization ALOS-1 is supported by PolSARpro but I’m not sure if two polarizations are sufficient for proper tomography results.
Maybe the theory part of this introduction clarifies this:

Please also consider that you need a few images at least.

Thank you…can you please help me how to create the Kz file and flat earth removal file for this data.While trying PCT, I got some problem

I just followed the tutorials which I listed above, the DEM file was automatically generated after starting the TomoSAR menu (sep 7). You have to enter some height values and a delta (I used the standard of 0.5) and then select “Gene”.

While trying to generate the histogram in PolSARPro v 5.1,I am getting error message like this:
“coordinates for -from option extend outside source image”.What should be the possible cause and how can I solve this?

Can you tell me how do you import SNAP products into Polsarpro and vice versa?

Did you see this tutorial:

The SNAP manual also provides some information on the import:

Export is also supported, but you have to check if all metadata are correctly written:

I am constantly getting this error while trying to import the polsarpro data in SNAP.

you are right, I get the same error. I tried modifying the metadata (data type is actually defined) but I also couldn’t manage it.

This is strange. It was possible in earlier versions maybe.

Hello , I am failing to add my data (Extracted from Single data set) in multi data sets (time series- PolSARpro). I followed 1-3 steps each UAVSAR data and tried to add main directory to Multi Data Sets (Time Series Data / Pol-Tom SAR), but its showing some error

Time Series.

I have never seen this error, sorry.

I am getting the same error. How did you rectify it?

please describe your data and the error message, “the same” is a little too unspecific.