Can not change default_userdir

I have edited SNAPInstallFolder\etc\snap.conf as per , but it doesn’t seem to make any difference. When I restart SNAP (v5.0) it still comes up using the cache path as C:\Users\<username>\.snap\var\cache. I do not have enough space in my home directory to use SNAP effectively and would like to mane it use D:\SNAP instead.


Actually there are two cache folder.
The default_user_dir specified in snap.conf points on Windows to <User_dir>\AppData\Roaming\SNAP.
The is used by the underlying NetBeans application platform.

Better change one of the properties in
It’s the second and disabled by default. Remove the ‘#’ and set the path.
The documentation in the file regarding this property seems to be not fully correct. In contrast what is stated there, It has effect on Engine mode (gpt ) and Desktop mode.

1 Like

Did my answer help you? I’m just asking because if this solves your problem I will update the FAQ.

If I change to include
then the options tool will not display its Performance tab. However if I use
then the Performance tab works and shows the Cache Path as D:SNAP\var\cache.

SNAP no longer seems to be using C:\Users\<username>\.snap\var\cache, as that is now empty.

Thank you for your help

Ok, thanks for this. I will update the FAQ accordingly.

Hello, I have changed the userdir path in like you have recommeded. But, I my case, It has worked changing the “” symbol to “/”. For example: snap.userdir=D:/Programs_files/.snap and not: snap.userdir=D:\Programs_files.snap
And now it seems to work properly. In the other case it seems like if the program does not recognize the path.