Error in running 'mt_prep_snap'

mazhuang@x7ti:~/2/INSAR_20190305$ mt_prep_snap 20190305 /home/mazhuang/2/INSAR_20190305 0.35
mt_prep_snap Andy Hooper, August 2017

Amplitude Dispersion Threshold: 0.35
Processing 1 patch(es) in range and 1 in azimuth

matlab: Command not found.
opening /home/mazhuang/2/INSAR_20190305/rslc/20190305.rslc…
Segmentation fault (core dumped)
6710
1809
mt_extract_cands Andy Hooper, Jan 2007

Patch: PATCH_1
selpsc_patch /home/mazhuang/2/INSAR_20190305/selpsc.in patch.in pscands.1.ij pscands.1.da mean_amp.flt f 1
file name for zero amplitude PS: pscands.1.ij0
dispersion threshold = 0.35
width = 6710
number of amplitude files = 0
Segmentation fault (core dumped)

psclonlat /home/mazhuang/2/INSAR_20190305/psclonlat.in pscands.1.ij pscands.1.ll
opening pscands.1.ij…
Error opening file pscands.1.ij

pscdem /home/mazhuang/2/INSAR_20190305/pscdem.in pscands.1.ij pscands.1.hgt
opening pscands.1.ij…
pscdem: Error opening file pscands.1.ij

pscphase /home/mazhuang/2/INSAR_20190305/pscphase.in pscands.1.ij pscands.1.ph
opening pscands.1.ij…
Error opening file pscands.1.ij

Please take a look at the following posts, The error is discussed there.

Source of the post

Have a look at the following post and all others within the same thread under the post,

Source of the post

Thank you, I think it may be a problem with my Linux system, the path name may have changed because I switched the system language, I plan to reinstall the system.

hello, Has your problem been solved? I had the same problem. Can you tell me how to solve this difficult problem? thank you .

To be honest, I don’t know where the problem is. I used Ubuntu 19.04 for temporary learning. Recently I bought a new and bigger hard drive, so I reinstalled Ubuntu 18.04.3 and related software, and the problem was solved. Maybe you can solve the problem by reinstalling the software without reinstalling ubuntu.

thank you for youor answer