SNAP 7, "The target was not found"

Hello alltogether,

I use SNAP 7 on Win10. Every time I do things in SNAP (like opening a folder or starting an operator) a new small splash window plops up with the message “snap64.exe Das Ziel wurde nicht gefunden” (engl.: “The target was not found”).

Here is a link to a screenshot: GoogleDrive.

However, after closing this message-window (I always have to close it 3-times, one-after the other) it´s possible to execute operators or open a file or whatever else.

Nevertheless, it bugs me and I´d like to find a solution to work without this problem, but I´m not an IT-spezialist. With SNAP 6 this problem did not occur, by the way.

Does anyone have an idea, how to solve this?

Best regards
Rainer

Hi,

this is a known issue. Probably you have an invalid link on your desktop.

See also the follwoing posts:

Hello!

I’m having the same problem. I read the posts but got lost. I don’t know how can I find this link to change it. Can you tell us how to solve the problem?
Thank you

Ana

what is the first folder that opens when you select “File > Open”
Check this folder in your file browser for invalid shortcuts.

Also, check the files/folders/shortcuts listed in the “quick access” of your system:

source: https://www.howtogeek.com/236711/how-to-turn-off-recent-items-and-frequent-places-in-windows-10/

Dear ABrown, thank you for your reply.

The first folder Snap tries to open is My Documents, but I get the same error (snap64.exe - Windows cannot find the target) every time I open something like a pin. It then opens in the last used directory (not always My Documents) after clicking OK 3 times. I did tried erasing the frequent places (following the instructions of the link), but nothing changed. I don’t know how ti check for invalid shortcuts from this or any folder.
I also updated Java, but nothing changed.
I noticed that I had no problem when I updated the Snap version in a Win10 in the office PC, while the problem is in my laptop which has Win7. Could this be related?
Thanks again.

Ana

it is not a matter of the version of your operating system, but rather specific to your machine.

Please check the folders you mentioned for folders which have this arrow on the bottom left and look like this:

grafik
source

Some of them is referring to a location of file which is no longer there. This causes the problem. Once you delete it, the error message should vanish.

Thanks a lot to all of You for your advices! I also could not solve this problem until now, although I checked all folders (I guess…) on my system. Just like Ana mentioned, on another PC everything is fine.
Best regards
Rainer

Please also check your desktop for outdated shortcuts

Yes, I did that, too. But also on my desktop are no shortcuts that lead to nowhere. Every existing link opens an app or a new folder.
Regards
Rainer

The same here. There are no shortcuts for any of the folders (not even in the Desktop). And it happens in whatever folder I’ve been last working (e.g. where the images are and no shorcuts exist). I also removed “Shortcut” Name Extension in Registry Editor as suggested, but no change at all.

Ana

I can only report that I had it once as well and then I removed all shortcuts in the following directories to a sub-folder it worked again. I then noticed that one

  • Desktop
  • User directory
  • User\Documents (check especially here, because this is the standard folder opened by SNAP)
  • Recently accessed files

I can reproduce this error by creating a folder and putting a shortcut to this folder in the user\documents folder:

Once I remove this folder and want to open a new file in SNAP, this invalid shortcut causes the error:

grafik

Once I remove this shortcut - the error vanishes.